phpSysInfo + lm_sensor

lordъ

jerk it out
Andy как работать с лм_сенсорс написано в
 

Andy

Well-Known Member
lm_sensor - что может эта программа, и как и где она настраивается, и как запускается? :) KSensor вот работает :)

Поставил у себя на сайте прикольную фишку, phpSysInfo. Ну знаете. В ней тоже должны отображатся температуры и вольтаж, через lmsensor. А ничего не отображается. Куда смотреть? :)



Вот тут можно посмотреть. Как видите, в самом низу датчики lmsensor ничего не показывают. Хотя в системе установлен пакет lm_sensor.
 
Последнее редактирование:

Lirk

Member
в файле /etc/phpsysinfo/config.php или /var/www/phpsysinfo/config.php
нужно прописать $sensor_program = "lmsensors";
Код:
// define the motherboard monitoring program here
// we support four programs so far
// 1. lmsensors  http://www.lm-sensors.org/
// 2. healthd    http://healthd.thehousleys.net/
// 3. hwsensors  http://www.openbsd.org/
// 4. mbmon      http://www.nt.phys.kyushu-u.ac.jp/shimizu/download/download.ht$
// 5. mbm5       http://mbm.livewiredev.com/

// $sensor_program = "lmsensors";
// $sensor_program = "healthd";
// $sensor_program = "hwsensors";
// $sensor_program = "mbmon";
// $sensor_program = "mbm5";
$sensor_program = "";
 

Andy

Well-Known Member
Да, именно так и прописано. Это я нашел.
 

Andy

Well-Known Member
Запустил и перезагрузился... не появилось :-(

[root@ut1ab andy]# /usr/sbin/sensors-detect
# sensors-detect revision 1.393 (2005/08/30 18:51:18)

This program will help you determine which I2C/SMBus modules you need to
load to use lm_sensors most effectively. You need to have i2c and
lm_sensors installed before running this program.
Also, you need to be `root', or at least have access to the /dev/i2c-*
files, for most things.
If you have patched your kernel and have some drivers built in, you can
safely answer NO if asked to load some modules. In this case, things may
seem a bit confusing, but they will still work.

It is generally safe and recommended to accept the default answers to all
questions, unless you know what you're doing.

We can start with probing for (PCI) I2C or SMBus adapters.
You do not need any special privileges for this.
Do you want to probe now? (YES/no): y
Probing for PCI bus adapters...
Use driver `i2c-viapro' for device 00:11.0: VIA Technologies VT8233A/8235 South Bridge
Probe succesfully concluded.

We will now try to load each adapter module in turn.
Module `i2c-viapro' already loaded.
If you have undetectable or unsupported adapters, you can have them
scanned by manually loading the modules before running this script.

To continue, we need module `i2c-dev' to be loaded.
If it is built-in into your kernel, you can safely skip this.
i2c-dev is not loaded. Do you want to load it now? (YES/no): y
Module loaded succesfully.

We are now going to do the adapter probings. Some adapters may hang halfway
through; we can't really help that. Also, some chips will be double detected;
we choose the one with the highest confidence value in that case.
If you found that the adapter hung after probing a certain address, you can
specify that address to remain unprobed. That often
includes address 0x69 (clock chip).
Can't exec "i2cdetect": Нет такого файла или каталога at /usr/sbin/sensors-detect line 5095, <STDIN> line 2.
Couldn't find i2cdetect program!! at /usr/sbin/sensors-detect line 5095, <STDIN> line 2.
[root@ut1ab andy]#
 

Lirk

Member
А если выполнить ~$ /usr/bin/sensors что нибудь выдает?
 

Michael

Well-Known Member
Команда форума
Администратор
а так?
Код:
modprobe i2c-viapro
modprobe i2c-dev
[COLOR="#909090"]/etc/init.d/lm_sensors start # (?)[/COLOR]
/usr/bin/sensors
 

Andy

Well-Known Member
Вот:

[andy@ut1ab ~]$ modprobe i2c-viapro
bash: modprobe: command not found

[andy@ut1ab ~]$ /sbin/modprobe i2c-viapro
[andy@ut1ab ~]$

[root@ut1ab andy]# modprobe i2c-viapro
bash: modprobe: command not found

[root@ut1ab andy]# /sbin/modprobe i2c-viapro
[root@ut1ab andy]#

[root@ut1ab andy]# /usr/sbin/modprobe i2c-viapro
bash: /usr/sbin/modprobe: Нет такого файла или каталога

[root@ut1ab andy]# /sbin/modprobe i2c-viapro
[root@ut1ab andy]#

[root@ut1ab andy]# modprobe i2c-dev
bash: modprobe: command not found

[root@ut1ab andy]# /sbin/modprobe i2c-dev
[root@ut1ab andy]#

[root@ut1ab andy]# /etc/init.d/lm_sensors start # (?)
[root@ut1ab andy]#

[root@ut1ab andy]# /etc/init.d/lm_sensors start
[root@ut1ab andy]#

[root@ut1ab andy]# /usr/bin/sensors
No sensors found!
[root@ut1ab andy]#
 
Последнее редактирование:
Верх